Auteur Topic: Tip Esu LokPilot v4.0  (gelezen 6672 keer)

0 leden en 1 gast bekijken dit topic.

Riny

  • Gast
Tip Esu LokPilot v4.0
« Gepost op: 28 november 2011, 08:42:10 »
Zoals bekend was de eerste firmware van de LoPi v4.0 niet om naar huis te schrijven betreffende het fijn configureren met de Esu (Hamo) permanentmagneten.
Het was ??n groot drama. :(

Inmiddels zijn er diverse update geweest betreffende de Software voor de LoPi v4.0 waarin ook de firmware "foutjes" gecorrigeerd werden.
Om er zeker van te zijn dat de laatste firmware in de decoder wordt weggeschreven, de volgende TIP.

Voor diegene die met de loc- programmer werken en ook de software 4.2.5. hebben ge?nstalleerd, het volgende.

- Plaats de Loc met ingebouwde decoder LoPi v4.0 (54610) op een programeerspoor of klein test ovaal.
- Verander nog niets aan de instellingen.
- Lees de decoder in en schrijf vervolgens de ingelezen data weer terug naar de decoder.

Op deze manier zit de laatst bijgewerkte firmware nu in de chipset van de Esu decoder LoPi v4.0
Vervolgens kan men nu de decoder naar eigen wensen qua rijgedrag fine tunen. ;)

Note: bij een volgende software update herhaald men dit zodat men er zeker van is de laatste (verbeterde) firmware in de LoPi 4.0 te hebben.
Aan de gedane instellingen zal niets worden gewijzigd alleen zal de firmware verbeteren.

Dat het goed werkt, daar ben ik zeker van.
Heb vanaf de eerste levering LoPi's v4.0 1 loc beschikbaar gehouden om deze vervolgens steeds een firmware update te geven.
De verbeteringen zijn duidelijk zichtbaar.

P.s. Dit is ook zo gegaan met de LoPi v3.0 / v3.5 al weten wij en de meeste dit niet.

Succes.

Piet

  • Gast
Re:Tip Esu LokPilot v4.0
« Reactie #1 Gepost op: 28 november 2011, 14:40:55 »
Voorwaarde is wel dat de PC een internet verbinding heeft, toch Riny?

grt Piet.

Riny

  • Gast
Re:Tip Esu LokPilot v4.0
« Reactie #2 Gepost op: 28 november 2011, 15:40:17 »
Voorwaarde is wel dat de PC een internet verbinding heeft, toch Riny?

Beste Piet,

Wanneer men de laatste software update heeft gedaan, dus op dit moment 4.2.5. voor de LoPi v4.0 of 2.7.9. voor de LoPi v3.0 / v3.5, zit de firmware gelijk in de software, dus deze komt mee met de software update.
Dus na installatie of update is, om de laatste firmware in de decoder weg te schrijven, deze aanwezig in de software en heeft men geen internetverbinding meer nodig.

Een internetverbinding is alleen nodig om de software (programma) te updaten, niet voor de firmware.

Wanneer men een Ecos en/of CS zou hebben en men wil de laatste firmware van d?t apparaat updaten, dan is er wel een internetverbinding nodig.
Wat dit laatste betreft, daar gaat het in deze LoPi Tip niet over.

Hopelijk heb ik het hiermee wat duidelijker mee gemaakt.

P.s. Hieronder de omschrijving van de laatste (4.2.5) software.

===========================================================

4Microsoft .NET Framework 3.5 SP1 is required. The .NET Framework will be installed automatically if the computer is connected to the internet.  Supported decoders:

    LokPilot V4.0
    LokPilot V4.0 DCC
    LokPilot micro V4.0
    LokPilot micro V4.0 DCC
    LokSound Select
    LokSound V4.0
    LokSound micro V4.0
    LokSound Select direct
    LokSound Select micro
    KM1 Smoke Unit

This software is also installing firmware version 4.5 on your decoder.
New Features

    LokPilot V3 Decoder import
    When trying to open an .esu file the import decoder dialog starts automatically
    Load control presets are now available via menu and toolbar
    Conversion from LokPilot to LokSound projects and vice versa
    Number of repetions can now be set for each state

Bugfixes

    Direction change did not work properly with imported LokSound V3 sounds.
    New states have not always been shown in the visible area.
    Main windows has not been visible after the process has been quit via task manager
    Reading decoder data into an existing project could remove sound data.

Decoder Firmare 4.5.9054

    Some locomotives stopped after receiving a direction change
    New load control parameter: "I slow"

========================================================

Piet

  • Gast
Re:Tip Esu LokPilot v4.0
« Reactie #3 Gepost op: 28 november 2011, 19:11:53 »
Ok, ik snap hem.
Vroeg me al af waar die firmware vandaan kwam, maar die zit in de software van de programmer.
Miijn baan laptop heeft nl geen internet verbinding.

Bedankt voor de info.

grt Piet.

Riny

  • Gast
Re:Tip Esu LokPilot v4.0
« Reactie #4 Gepost op: 28 november 2011, 19:54:31 »
Miijn baan laptop heeft nl geen internet verbinding.

Graag gedaan.

Download de software, opslaan op een USB- stik en ga naar boven, steek hem in de Laptop en klaar is Piet. ;) ;D

Piet

  • Gast
Re:Tip Esu LokPilot v4.0
« Reactie #5 Gepost op: 28 november 2011, 20:51:05 »
Is inmiddels gebeurd!
De NS1200, weet je wel van die zelfgemaakte koppelingen rijdt nu langzaam stukken beter.

grt Piet.

Riny

  • Gast
Re:Tip Esu LokPilot v4.0
« Reactie #6 Gepost op: 28 november 2011, 21:42:51 »
Gefeliciteerd Piet,

Dat zijn alvast de eerste vruchten die je geplukt hebt.
Helemaal top.